1E Inventory Insights unavailable

Incident Report for 1E

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 14:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 31, 2025 - 04:17 UTC

Investigating

Some users are currently experiencing issues opening the Inventory Insights module on the 1E Platform
Posted May 30, 2025 - 22:35 UTC
This incident affected: 1E Platform - East US 1.